Workflow Test Sequence Hangs
Symptom
When running the Workflow Test on a machine that is joined to a domain, the test hangs at the step "Starting sequence <sequence>."
Cause
The Test Services service must run under the same user account as the Instrument service. If they are running under different accounts, the Workflow Test cannot start a sequence.
note
The user account may be a domain account or, for a workstation not joined to a domain, a local Windows user account.
Resolution
Update the Test Services service to run under the same user as the Instrument service:
- Verify the user account under which the Instrument service is running.
- Log in as a Windows domain user who has local administrative privileges.
- Go to Control Panel > All Control Panel Items > Administrative Tools and double-click Services.
- Right-click Agilent Test Services Service and select Properties.
- Click the Log On tab, select This account, and enter the login credentials of the user used for the Instrument Service. Click OK.
- The Services window confirms that the account has been granted the Log On As A Service right. Click OK.
- Click OK to acknowledge the message: "The new logon name will not take effect until you stop and restart the service."
- Restart the Agilent Test Services Service.
- Log in using the same user account specified in the Log On tab of the Agilent Test Services Service Properties window.